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I ntroduction

Thislab introduces you to special relativity and, hopefully, gives you some
intuitive understanding of its basic phenomena of “time dilation,” “Lorentz length
contraction” and the special way speeds of fast moving objects add together. Y ou will
use a computer simulation during this session that lets you examine the behavior of
simple objects (rods and clocks) when they travel at very large speeds along a straight
line. All of the motion takes place along a straight highway and objects are allowed
only to go forward or in reverse. Y ou will control the speed and direction of motion of
these objects, subject only to the constraints that the physics of special theory
relativity imposes on them, first discovered by Einstein in 1905. In case you were
wondering, the “special” in special relativity stands for “ special case” and signifies
that the theory of special relativity isasimplification of the more complete theory of
“Genera Relativity.”

There are two main points to special relativity. First, imagine you and your lab
partner are each in specia rooms that contain all of your lab equipment. Y ou look out
the window of your room and see that your partner’sroom is moving at some constant
speed with respect to you. She is either approaching or receding at a constant rate.
After waving, you both close your respective windows so that neither of you can
directly observe the outside world and perform all sorts of physics experiments. Based
on the results of your experiments, you would not be able tell whether you were
moving or your lab partner was moving. That is, the results of the experiments are the
same whether you are moving or standing still. Similarly, your lab partner would not
be ableto tell if she were the moving one or the one at rest. Thisis the meaning of
relativity.

The second important point is that both you and your lab partner would
measure the speed of light travelling through empty space as having the very same
value, even though your lab partner is travelling with some speed with respect to you.
Although not obvious, thisimplies that the speed of light is somehow the part of the
essential fabric of the physical universe. The speed of light through empty spaceis
typically given the symbol ¢ and has been carefully measured to have the value
c=3x10% m/sec.

Our simulation program automatically calculates all the numbers we require to
develop an understanding of how time, length and speed are affected by SR. You
need, however, to learn a small number of commands to manipulate the rods and
clocks to send them on their way in the appropriate direction and with the appropriate
speed. A detailed list of these commandsisincluded in the lab. Y ou only need to
learn about 10 or so. Finally, it isimportant to understand that today you will perform
asmulation of special relativistic effects. The simulation assumes that special
relativity is correct and lets you explore the consequences of this assumption. The



softwar e does not test whether or not special relativity iscorrect in thefirst
place. What you do today is not really an experiment.

Procedure

1

L ocate the folder Spacetime. The instructor will help you if you can’t locate it.
Double click (left mouse button) on the icon Spacetime.

In the reference materia below, read the section The Highway Window. This will
explain to you what you are staring at on the screen. Y ou need to play abit so that
you learn a few commands to get something interesting to happen. Read and
perform the Tutorial, which is also included in the reference section of thislab.
What is most relevant to you is to know how to create rods, clocks, clock strings
and so-called shuttles. Also, you will need to know where to look to find things
like the speed and position of these things. Y ou do not need to memorize every
command. The point of the tutorial isto familiarize you with the program. This
will probably take 20 minutes or so. Have fun.

Now we are ready to start by learning how lengths are modified by special
relativistic effects. Create 4 rods at dightly different positions (x=0.5, 1.0,1.5 and

2.0) Give them 9 values of 9 =0.6,0.8,0.95 and 0.99. | will refer to these rods as
rod B (x=0.5) rod C (x=1.0) and so on.

Question 1. What is the corresponding value 1 for each value of 9?

Fill in datatable 1 below. On a piece of graph paper, plot 1 v. 9. (This mean that
the vertical axis should be 1 and the horizontal axis should be 9. Draw a smooth
curve through the 5 points. (You can use the clock at the origin even though it
isn't arod because we are only interested right now in the relationship between 9
and 1.) Question 2. What do you notice about the apparent length of the rods?

Fill in datatable 2 below. Can you make a genera statement about the lengths of
objects when they are moving very rapidly with respect to you?

Thisexerciseillustrates that if we take into account special relativity, “moving
objects’ appear shorter than they do when their length is measured in their own
rest frame. These objects are “Lorentz contracted” by an amount that depends on
their speed. The greater their speed, the greater their contraction. It is important to
understand that | am NOT talking about an optical illusion. | am talking about the
length you would measure with aplain old ruler or similar device.
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We now examine how time behaves when we take into account special relativistic
effects. Delete the rods you have previously created and start with a fresh screen.
Create 4 clocks (C, D, Eand F) at x=0.5, 1.0, 1.5 and 2.0, and give them the 9
values of 0.6(clock C), 0.8 (D), 0.95 (E) and 0.99 (F). Y ou should see atotal of 5
clocks on your screen, including the one (clock B) that is at rest (9=0). Make
certain you are in the reference frame of clock B (that’s the one at rest) and
advance the time on clock B until it reads 10.0 seconds. Examine the times on all
the other clocks. Fill in datatable 3. You may find it useful to use the so-called
Object Table found under menu Windows.

Question 3. What clock seems to be running the slowest? Write down a genera
statement about the rate at which aclock “runs’ and the speed of a clock.

Jump to the reference frame of clock F. Advance clock F until it reads 10.0
seconds. Examine the object table. Question 4. Isthere any difference between
the Object Table now and when you were in reference frame B? Why do you
think that is?

This exerciseillustrates the phenomenon that according to special relativity,
“moving clocks run slow.” Actually, moving clocks do not run any slower than
they should, unless they are mechanically defective. It isjust that what we mean
by a“second of time” depends on the reference frame we arein.

We will now examine how speeds add when we take into account special
relativistic effects. Delete all the clocks you made previously. We will create 5
rods in succession, each with a speed 0.5c¢ faster than the rod beforeit. All of the
rodswill be at x=0. First, create rod A with 9=0. Next, create rod B with 9=0.5
also at x=0. Jump to reference frame B and create anew rod C at x=0 that has a
speed 0.5¢ with resect to rod B. This means that somebody standing on rod C will
see rod B move away from them with a speed equal to half that of light’s.
Continue by “transforming” (jumping) to rod C and creating arod D that has
speed 0.5¢ with respect to rod C. Finally, transform to rod D and create arod E
with 9=0.5 with respect to D.

Transform to reference frame E (the frame of the last rod you made).

Question 5. What is the speed of rod D as seen from rod E? (Express your answer
as9=...)

Question 6. What is the speed of rod A as seen by somebody standing on rod E?

Transform back to frame A, the original frame. Question 7. What is the speed of
rod E as seen from A? Question 8. What is the speed of rod B as seen from A?
Question 9. What is the similarity between the object tables when you are
standing on rod E and when you are standing on rod A? Try to be as specific as
possible about what this similarity is.

Did you notice that even though you kept creating rods that were moving with half the
speed of light (9=0.5) with respect to the preceding rod, you were never able to create



arod moving faster than the speed of light? Doesn't this seem strange? This exercise
illustrates that c is alimiting speed for al objects in the universe.

Reference M aterial



About the Program

B THE HIGHW A'Y 10
The Highway Window

When the program starts, you see the Highway window, a
“superhighway” running from left to right across the screen
(see Figure 1). Different lanes on the highway are for objects
moving at different speeds. Objects lying on the dashed
horizontal line through the middle of the screen are on the
center strip of the highway and do not move. Objects above
the center move to the right; the farther above the center,
the faster they move. Objects in the very top lane move to
the right with the speed of light; only light flashes (and
neutrinos) can occupy this lane.
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Fig. 1. Objects moving in one dimension are displayed in the Highway
window on a left-to-right “superhighway” with objects moving at
different velocities spread out vertically into different "lanes.” Shown
here is the classic Train Paradox scenario at the moment the backward-
moving light flash (at the bottom of highway) reaches the center of the
train moving to the right. The features of this window are described
below in the section “Exploring the Highway.”



Objects below the center of the screen move to the left;
the farther below the center, the faster they move. Objects in
the very bottom lane move to the left with the speed of
light; only light flashes (and neutrinos) can occupy this
lane.

The highway convention is British, but modified; ve-
hicles drive on the left side, but slow lanes are near the
center strip, fast lanes near the edge of the road.

To understand what appears on the highway, think of it
as a movie of all the objects traveling along the highway. At
any given instant, you are looking at a single “still” of the
movie. As you click the buttons labeled “+t” and “~t” at the
lower right corner of the window you simulate the passage
of time by looking at the next or the previous still-frame of
the movie. You are going to learn how to make such
movies.

A vertical ruler at the left of the screen shows f (Greek
beta), the velocity as a fraction of the speed of light: B=1v/c.
The range of § extends from +1 at the top (light moving to
the right), through 0 at the center, to -1 at the bottom (light
moving to the left). Notice that this is not a linear scale;
equal vertical lane separations do not correspond to equal
changes in B. This is done so that more of the interesting
velocities near 8 = v/c = £1 can fit on the screen.

There is a scale on the screen labeled ynext to the S scale.
Ignore this second scale for now.

The numbers at the lower left corner of the screen ‘
describe the position of the pointer on the screen. The first
number, ¢, is the time as measured in the current reference
frame. This number stays constant as you move the mouse
and changes only as you step through time. The number
next to it, x, is the right-left position of the pointer on the
highway. The second line shows the § and y(Greek gamma)
of the velocity of the lane to which the pointer is pointing.

Before learning more details of the Highway window,
take a quick spin to get the feel of it. The next section is a
tutorial to introduce you to SPACETIME.

| TUTORIAL I

This fifteen-minute tutorial introduces you to the program
by guiding you through an example journey on the high-
way.

To start SPACETIME, do the following;:

1. Turn on your Macintosh



2. Insert the SPACETIME disk into a disk drive

ﬁ 3. When the directory window opens, double-click the
Spacetime icon labeled SPACETIME
The program displays the title of the program and the name
of the author.

Click the OK button to proceed

The naked-eye star nearest to our sun is Alpha Centauri,
about four-and-a-half light-years distant from us. Assume
that the distance units shown along the center strip are
light-years and the time units on the clocks are years. The
“reference clock” in the center of the screen represents
Earth with observer. Now create a second clock to represent
Alpha Centauri. At the bottom of the screen in the objects
palette is a clock icon. It looks like this:

You create an object by dragging the corresponding icon
onto the highway. To aid you in positioning objects, the
numbers at the lower left corner of the window show the
position of the pointer when the pointer is on the highway.

Drag a clock icon to the position x = +4.5 and velocity
B = 0.0. This clock represents Alpha Centauri.
Next, prepare a shuttle for the trip to Alpha Centauri. The

initial position of the shuttle is the same as Earth (x = 0) and
its initial velocity is B = 0.9. The shuttle icon looks like this:

S

Drag the shuttle icon to the position x = 0.0 and velocity
B=09
Now start the shuttle on its journey by stepping time

forward. The buttons for changing the time are located in
the lower right corner of the screen.

Click the +t button twice

The shuttle has moved closer to Alpha Centauri. It arrives
when it lines up vertically with the clock located at x = 4.5.
You need to see detailed, numerical information about the
shuttle as it moves.

Click the shuttle (on the highway)

The icon changes to white on black. A line of information
across the bottom of the highway shows the shuttle’s



position, speed, and the reading on its clock. This informa-
tion is updated as you move the shuttle toward Alpha
Centauri.

Click the +t button three times

The shuttle has arrived at Alpha Centauri. Now move the
shuttle into a lane moving to the left so it is heading home,
as follows:

Choose Program Shuttle from the Objects menu

A box appears with numbers and buttons in it. Find the
buttons that look like this:

@ B>0
O B<0

These buttons determine whether the shuttle is moving to
the right (with a positive velocity 8> 0), or moving to the
left (with a negative velocity 8 < 0). The black dot in the
circle means that the positive velocity is selected right now.

Click the <0 button
The black dot moves to the lower circle.
Click the OK button

The shuttle is now programmed to turn around when it
reaches Alpha Centauri. Now bring the shuttle home:

Click the +t button five times

Welcome the shuttle home. You observed everything while
standing on the center strip, so you did not move! To record
the arrival as an event:

Choose Object Event from the Objects menu

The event is displayed as a vertical line across the highway.
This emphasizes that the objects are actually located on a
single line in space—the vertically separated velocity-lanes
are just a way of avoiding screen clutter.

Compare the time on the Earth clock to the time on the
shuttle clock. Each clock shows the number of years that
has passed. Who is younger, the shuttle pilot or the stay-at-
home twin? This is called the Twin Paradox. For a further
analysis of the Twin Paradox, see “Some Relativistic
Effects.”

Now repeat the journey while you, the observer, are
riding on the shuttle. First reset the time to zero:

Choose t = 0 from the Options menu

Now climb onto the shuttle (if the shuttle is not still shown
as white-on-black, click it to select it):



Choose Jump to Object from the Transform menu

You are now riding on the shuttle. With respect to you (the
observer) the shuttle is at rest so the shuttle is on the center-
strip of the highway. Earth is lined up with you but below
you, in a leftward-moving lane. Alpha Centauri is in the
same lane as Earth, located to the right of Earth. Because
Earth and Alpha Centauri are moving in your rest frame,
the distance between them is contracted according to the
laws of special relativity.

Noticed that when observed from the shuttle, the Earth
clock has a different reading than the clock on Alpha
Centauri. This is due to the relativistic effect called “relative
synchronization of clocks.” When two clocks are both at
rest on the center strip, they do have the same reading—
they are “synchronized” with one another. This is discussed
in “Some Relativistic Effects.”

Click the +f button seven times

The “movie” of the trip to Alpha Centauri and back to Earth
is replayed as observed while riding on the shuttle. The
shuttle automatically turns around when it reaches Alpha
Centauri and stops when it reaches Earth. Welcome home.

Choose Quit from the File menu

A dialog box appears asking if you want to save your work,
Click the No button

This concludes the tutorial.

» EXPLORING THE HIGHWAY I

You have already used many of the most important High-
way window commands. Now it is time to examine the
Highway window more closely. The Highway window
(shown in Figure 1) automatically appears when you start
SPACETIME. When you view another window, the High-
way window becomes hidden.

To view the Highway window, choose Highway from the
Windows menu (or press (1))

This section of the manual describes the following:
¢ The concept of the highway

» Things that can appear on the highway

» How to create things on the highway

e How to change things on the highway

* How to delete things from the highway



one-dimensional

units

gamma scale

animation vs.
observation

¢ How to change the time
e How to change the reference frame
¢ How to change the view of the highway

The Concept of the Highway

The vertical separation of objects by velocity on the high-
way is just for analysis. In reality all the objects are moving
along a single line, a single dimension in space. SPACE-
TIME artificially separates them vertically on the screen in
order to analyze their relative motions without screen
clutter. An event is represented as a vertical line across the
entire highway to remind you of the artificial vertical
separation in the window.

The short vertical lines along the center strip of the
highway are one unit of distance apart. SPACETIME uses
abstract units. You may choose any units to measure time
and space that suit your purposes. The only constraint is
that light move 1 unit of distance in 1 unit of time. Hence,
consistent units might be years of time and light-years of
distance, or minutes of time and light-minutes of distance
(one light-minute equals the distance that a flash of light
moves in one minute), or meters of distance and meters of
light-travel time (one meter of light-travel time equals the
time it takes for a light flash to move one meter), etc. Thus,
you control the scale of events.

Immediately to the right of the f3 scale (described above
in “The Highway Window”) is a second scale labeled y that
gives the value of y(Greek gamma), sometimes called the
time stretch factor.

Moving clocks appear to run slow by the factor y and
moving rods appear to be contracted by a factor y along
their direction of motion. The factor %, which is always
positive, ranges from the value infinity at the top of the
screen, through the value 1 at the center, to the value
infinity again at the bottom of the screen.

m

Y

You cannot run time backward in real life. Thus, you
must always remember that the highway does not show
events as they are occurring, even in principle. Rather it
replays data gathered from remote locations, transported to
a central information processing facility, and assembled
into a picture-by-picture animation, which can be run
backward or forward in time at your pleasure.

10
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The titles of the pull-down menus appear across the top
of the screen. Commands are grouped by function, so, for
example, filing operations can be found in the menu titled
File.

Many of the menu commands have keyboard equiva-
lents. These are listed beside the command within the
menu. In this program it is not necessary to hold down the
key while pressing the keyboard equivalent of a menu
command.

At any time you can obtain on-screen help about the
commands by either pressing (2] or choosing Help from the
& menu. A different help screen appears for each window.
Click anywhere to resume using the program.

Things That Can Appear on the Highway

A clock appears as an icon that looks like the face of a clock.
Since moving objects appear to be shortened, the icon of a
moving clock appears narrowed on the screen. The time
reading of the clock is shown below the icon.

Each clock ticks at its regular rate in the frame of refer-
ence in which the clock is stationary, but to an observer in
relative motion, the clock appears to run slow.

The clocks in a given frame are said to be “synchro-
nized” when the following is true: Jump to their frame so
that all the clocks are at rest. If all the clocks read the same
time, they are synchronized. A clock on the highway is
automatically synchronized in its rest frame unless you
manually set its time. The time on an unsynchronized clock is
shown in outlined numbers {(e.g., £.00).

When two synchronized clocks are both at rest on the
center strip, they read the same time. However, two syn-
chronized clocks moving in the same highway lane do not
read the same time. This is due to a relativistic effect called
the “relative synchronization of clocks.” Most people have
trouble understanding this relativistic effect. For more on
relative synchronization of clocks, see “Some Relativistic
Effects.”

A clock string can be attached to a clock, rod, or shuttle.
The clock string is an infinite set of synchronized clocks
spaced regularly in the same lane as the object to which the
clock string is attached. To avoid screen clutter caused by
the Lorentz contraction, moving clock strings are displayed
with some of the clocks omitted. The spacing between
clocks in a clock string is 1 unit (in the rest frame of the
object) if the object is moving with a ybetween 1 and 2. The
spacing is 2 if yis between 2 and 3, and so on. Thus, the
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apparent distance between adjacent clocks in the string does
not correctly follow Lorentz contraction.

A rod appears as an icon that looks like a ruler. The
length of the rod in its rest frame is the distance a flash of
light travels in one unit of time. A rod always has the same
length in the frame of reference in which it is stationary, but
is observed to be shortened in a frame in which the rod is
moving,.

A flash of light appears as an icon that looks like an
asterisk. All flashes of light move at the same speed in all
inertial frames of reference. On the one-dimensional
highway, a flash of light can have a velocity of either f=+1
or B=-1. Hence, flashes appear only in the two outermost
lanes.

A beacon can be attached to a clock or a rod, but not to a
flash or the shuttle. Starting at time zero, each time the
clock of the object to which the beacon is attached increases by
one unit the beacon emits two flashes of light, one forward
and one backward.

The shuttle icon represents a clock that you can program
to follow a planned trip by changing its velocity lane on the
highway. (How to program the shuttle is explained later in
this section.) For example, the shuttle enables you to
measure the time of a round-trip journey. Only one shuttle
is allowed on the highway.

When you create a shuttle, its clock is synchronized and
set to time zero. From that time on the shuttle’s clock runs
continuously. Unlike an ordinary clock, when you change
lanes the shuttle’s clock is not synchronized with the “local
clocks” in its new lane. To remind you of this, the shuttle’s
time is displayed in outlined numbers (for example, 4.00)
whenever it is unsynchronized in its rest frame. Whenever
you wish, you can re-synchronize the shuttle to the time as
measured at its position in its local frame by selecting it and
using the Synchronize clock command in the Objects menu.
However, it will then be out of synchronization when it
jumps to other frames (including earlier frames).

An event is defined by both a particular time and a
particular location. On the highway, an event appears as a
vertical line and is displayed only at the time (in the frame
of the observer) when that event occurs. (Events are listed
on the Table window and continuously shown on the
Spacetime Diagram window.) When you incrementally
change time, the clock automatically stops at the time of
every event, even if the event occurs within a time step, to
avoid skipping over an event (unless you toggle this feature
off in the Options menu).
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Events are numbered 1, 2, 3, and so on in the order you
create them (not necessarily in chronological order). The
event 0 (event number zero) is a special one: by definition it
occurs at f = 0 and at x = 0 in all reference frames. Event 0 is
called the reference event because it is the starting gun from
which clocks are synchronized in every reference frame.
Event 0 is created automatically when you start the pro-
gram.

Examples of other possible events include a collision, the
emission of a flash of light, or a coincidence (the place and
time at which two objects have the same position).

Creating Objects Using the Mouse

To place an object, you simply drag the appropriate icon
from the object palette at the bottom of the screen onto the
highway.

1. Use the mouse to position the pointer over the
object’s icon (the pointer changes to look like a hand)

2. Press and hold down the mouse button
3. Use the mouse to drag the icon up onto the highway

As you move the object, its position and velocity coordi-
nates are displayed at the bottom left comer of the screen
(for example, x = 4.00 and B = -0.50000 y= 1.1547). The
position coordinate is automatically rounded to the nearest
multiple of 0.25 units. (If you wish to position objects more
precisely, toggle off the Round Coordinates option of the
Options menu.)

4. When the object is where you want it, release the
mouse button

If you change your mind and do not want to create the
object, simply drag the object off the highway before
releasing the mouse button.

Clocks and rods are shown Lorentz-contracted by an
amount appropriate for the velocity of the lane. Flashes of
light can travel only at the speed of light and so can be
placed only in the two outermost lanes.

Creating Objects Numerically

An alternative way to create an object is to enter numerical
values for its position and velocity.

1. Choose Enter Object from the Objects menu
A dialog box appears on the screen as shown in Figure 2.
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Fig. 2. The object parameters dialog box enables you to create or modify
an object numerically.

You can move around within the dialog box by clicking
what you want to select or enter.

3. Make the desired selections and entries as described
below:

Choose whether to specify the speed asa Bora
Gamma by clicking the appropriate button

Type the speed value (8 between ~1.0 and 1.0, or
Gamma any positive value greater than or equal to
1.0)

Choose the direction of motion by clicking f <0 for
motion to the left or >0 for motion to the right

Type the desired position coordinate

Type the desired time (to synchronize the clock with
other clocks in the same lane, click the Synchronize
box)

Choose the type of object by clicking the Clock, Rod,
Flash, or Shuttle button

Attach a clock string or beacon to the object by
clicking the corresponding box

You can annotate the object if necessary by typing up
to 255 characters in the Description box (for display in
the Table window)

4. When you have made all your choices and entries,
click the OK button

The dialog box disappears and the object appears on the
highway.
Selecting an Object

To select an object, simply click it. The icon of the object
inverts, becoming a white outline on a black background.



When two icons are overlapping, be careful that you click
the object you really want.

When an object is selected, information about its speed,
position, etc. is displayed near the bottom of the screen, just
below the highway.

To have no object be selected, click anywhere on the
highway that there is no object. When no object is selected,
the message “No object is currently selected” appears
below the highway.

Adjusting an Object

Sometimes by accident you place a clock, rod, or flash on
the screen in a slightly different location than you want it to
be. For example, you may accidentally place an object with
B =0.81 when you wanted it to have f = 0.80. You can edit
this and other object parameters in either of two ways. The
first way is to do the following;:

1. Hold down
The pointer shape changes to a hand.

2. Drag the object to its new location

3. Release the mouse button and release
The object appears in the new location.

Alternatively, you can change an object the following
way:

1. Select the object by clicking it

2. Choose Edit Object Details from the Objects menu (or

press (E))

A dialog box appears enabling you to alter the object (see
Figure 2 above). You can move around within the dialog
box by clicking what you want to change.

3. Make the desired changes as described below:

The method of specifying speed is changed by
clicking either  or a Gamma

The speed is changed by typing the new speed value
(-1.0< B <1.00r 1.0 £ Gamma)

The direction of motion is chosen by clicking 8 <0 for
motion to the left or 8 >0 for motion to the right

The position is changed by typing the position
coordinate desired

The time on the clock is set by typing the time desired

(to synchronize the clock with other clocks in the
same lane, click the Synchronize box)

15



The type of object is changed by clicking the Clock,
Rod, Flash, or Shuttle button

A clock string or beacon is attached to the object by
clicking the corresponding box

An annotation to the object (up to 255 characters) can
be typed in the Description box (for display in the
Table window)

4. When you have made all the changes you want, click
the OK button

Creating a Clock String or Beacon

To create a clock string or beacon, first create a clock, rod, or
shuttle and then attach the clock string or beacon to the
object.

1. Select the object by clicking it

2. Choose Beacon or Clock String from the Objects
menu

Deleting an Object

You can delete an object from the scenario. If you delete an
object, any events, clocks strings, or beacons associated with
that object are also deleted.

To delete a particular object, do the following:
1. Select the object by clicking it
2. Choose Delete from the Objects menu

You can delete all of the objects to clear the scenario. This
also resets the time to zero.

To delete all the objects and reset the time to zero, do
either of the following;:

Choose Clear All from the Objects menu (or press (a))
OR
Choose New from the File menu (or press (N))

Creating an Event at an Object

You can create an event at the current location of any object.
To create an event at an object, do the following:
1. Click the object to select it
2. Choose Object Event from the Objects menu

The time of the event is set to the time as measured in the
current reference frame.

16
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You can also create an event at any position and time
using the Enter Event... command described in the next
section, “The Spacetime Diagram.”

Programming the Shuttle

The shuttle is simply a clock that follows a series of pro-
grammed velocity changes (in other words, a script) that is
replayed as you change the time.

To program the shuttle, do the following:

1. Create the shuttle and click on it to select it (see
“Creating Objects" above)

2. Change the time (see “Changing Time” below) to the
time you want the velocity change to occur

3. Choose Program Shuttle from the Objects menu (or
press (G))

A dialog box identical to the one used to edit objects
appears (see Figure 2).

4. Type the new velocity
5. Click OK
Alternatively, after step 2 you can do the following:

3. Hold down and drag the shuttle to the lane of
the new velocity

Two shuttles are now drawn on the screen: both at the same
position but one at the velocity just before the jump and one
at the new velocity. Only one shuttle exists, but it appears
in two lanes because at the moment of the jump the velocity
is undefined. At times prior to the jump, one shuttle ap-
pears in the old velocity lane; at times after the jump, one
shuttle appears in the new velocity lane.

The shuttle can make as many velocity changes as you
wish, but each velocity change must be made in chronologi-
cal order. If you insert an additional velocity change into
the shuttle’s program, all subsequent velocity changes
previously programmed are erased. A history of the
velocity changes of the shuttle is listed in the Table window.

You cannot change the spatial position of the shuttle
using either programming method. To do so would be to
allow an instantaneous change in the location of the shuttle,
which is physically impossible. If you find that you placed
the shuttle in the wrong lane, delete it and create a new
shuttle. By using the Enter Object command of the Objects
menu, you can position the shuttle accurately.



18

Appendix A: How to . ..

This appendix lists commands by the actions they carry out
(erase, create, etc.). Look for action verbs, listed alphabeti-
cally. Each description is very specific and brief—a quick
reminder. Alternative ways to do the same thing are not
listed. Fuller descriptions can be found in Appendix B
under the menu that includes the command.

Align two objects 1. Click one object

Choose Align from the Objects menu

3. Click the other object
(Does not work for Shuttle or for flashes emitted by a
Beacon)

{ad

Annotate event Choose Spacetime Diagram from the Window menu
Choose Select tool (an arrow) from the tool palette
Click the event

Choose Edit Event from the Objects menu

Type a comment in Description Window

Click the OK button

(Comment appears in the Table window)

Aol ol S .

Annotate object Choose Highway from the Window menu

Click the object

Choose Edit Object Details from the Objects menu
Type a comment in Description Window

Click the OK button

(Comment appears in the Table window)

G o=

Call See “Display”

Change frame In Highway:

1. Click the object you want to jump to
2. Choose Jump to Object from the Transform menu



Create event
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In Highway:

1.

2.
3.

Change time (see above) to time when event is to
occur

Select object at which event is to occur

Choose Object Event from Objects menu

In Spacetime Diagram:

1.
2.
3.

4.

Click the Event tool (top one; pointing finger)

Click the Create button

Position the pointer at the desired position x and time
t (numerical values displayed at lower left)

Click mouse

Create flash

[y

Choose Highway from the Windows menu

Drag a flash icon from the bottom of the screen to the
desired location on the top or bottom lanes of the
highway (position x and velocity f are shown at
bottom left corner)

Create hyperbola

Choose Spacetime Diagram from the Windows menu
Click the Hyperbola tool (a curved line) from the tool
palette

Click the Create button

Click the event the hyperbola should pass through

Create lightcone

Choose Spacetime Diagram from the Windows menu
Click the Lightcone tool {two crossed lines) from the
tool palette

Click the Create button

Click the event the lightcone should originate from

Create rod

Choose Highway from the Windows menu

Drag a rod icon from the bottom of the screen to the
desired location on the highway (position x and
velocity 8 are shown at bottom left corner)

Create shuttle

bt

Choose Highway from Windows menu

Drag the shuttle icon from the bottom of screen to the
desired location on the highway (position x and
velocity ff are shown at bottom left corner). Only one
shuttle can be placed on the highway



Delete connection

. Choose Spacetime Diagram from Windows menu
. Select Connect tool (a line connecting two dots) from

tool palette

. Select Delete button
. Drag the pointer from one event to the other (the

connection line disappears when the mouse button is
released)
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Delete event

. Choose Spacetime Diagram from Windows menu
. Select the Event tool (top one; pointing finger) from

the tool palette

. Select the Delete button
. Click the event

Delete hyperbola

. Choose Spacetime Diagram from Windows menu
. Select the Hyperbola tool (a curved line) from the tool

palette

. Select the Delete button
. Click the event the hyperbola passes through

Delete lightcone

. Choose Spacetime Diagram from Windows menu
. Select the Lightcone tool (two crossed lines) from the

tool palette

. Select the Delete button
. Click the event the lightcone originates from

Delete object

. Choose Highway from Windows menu
2. Select the object
. Press the (Backspace] or (Delete] key

Disconnect

See “Delete connection”

Display help screen

. Choose Help from the ® menu (a different help

screen appears for each window)

. Click anywhere to resume from where you were

Display information
about object

. Choose Highway from Windows menu
. Select the object

(Information appears on line below the highway)

Display Table

. Choose Table from Windows menu



Erase See “Delete”
File See “Save,” “Open”
Get  See “Display”
Goto See “Jump to” and “Transform”
Help See “Display Help Screen”
Jump to object 1. Choose Highway from Windows menu
2. Select the object
3. Choose Jump to Object from Transform menu
Magnify 1. Choose Zoom In from Options menu
Move object To move object by changing the time, click

+t or —f buttons

To move object without changing the time,

1. Select the object

2. Choose Edit Object Details from Objects menu
3. Make changes

4. Click OK button

Move screen left or
right

1. Click < or > button

Move screen up or
down

In Spacetime Diagram,
1. Click +t or -t button

In Split Window,
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1. Use scroll bar arrows or slider to move the highway

2. Click +t or - buttons to move Spacetime Diagram

3. Drag black dividing bar to change which window is
more exposed

New scenario 1. Choose New from File menu

—r

Open scenario . Choose Open from File menu
file 2. Double-click title of desired scenario file



Print
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N

1. Choose window you want to print using Windows
menu
2. Choose Print from File menu

Program Shuttle

1. Choose Highway from Windows menu

2. Hold down the key (pointer changes to a hand)

3. Drag shuttle to lane of new velocity (coordinates
shown on screen at lower left)

Quit

1. Choose Quit from File menu (you are asked if you
want to save any changes you have made)

Read scenario file

See “Open scenario file”

Round Coordinates

1. Choose Round Coordinates from Options menu
(when checked, pointer coordinates are rounded to
nearest 0.25 unit)

Save scenario file

1. Choose Save from File menu to save using same
name, or

1. Choose Save As from File menu to save using a
difterent name

Select

1. Click object or event you want selected {to have
nothing be selected, click a blank area of the window)

Show

See “Display”

Split the window

1. Choose Split Window from Windows menu

Synchronize clock

1. Choose Highway from Windows menu
2. Select clock to be synchronized
3. Choose Synchronize clock from Objects menu

Transform frame

In Highway,
1. Select object to whose frame you want to jump
2. Choose Jump to Object from Transform menu

In Highway or Spacetime Diagram,

1. Choose Transform up or Transform down from
Transform menu (select size of change by choosing
appropriate d = from Transform menu), or
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1. Choose Enter b, Gamma from Transform menu
2. Select b or Gamma button
3. If entering g, click b <0 or b >0
4. Type in numerical value
5. Click OK button
Transform to last 1. Choose Last Frame from Transform menu (The last
fmmg frame is the frame previous to the current frame)
Transform to original 1. Choose Original Frame from Transform menu (The
frame original frame is the frame at the beginning of the
scenario)
Turn on/off interval 1. Choose Spacetime Diagram from Windows menu
labels 2. Choose Display Interval from Options menu (when a
v appears on the menu, the interval labels are being
shown)
Turn on/off 1. Choose Spacetime Diagram from Windows menu
worldlines 2. Choose Display Worldlines from Options menu
(when a v appears on the menu, the worldlines of all
objects are being shown)
Unselect 1. Select something else, or
2. Click a blank area of the window
Unsynchronize 1. Choose Highway from Windows menu
clock 2. Choose Edit Object Details from Objects menu
3. Click inside the Time on Clock box
4. Type numerical value of new time
5. Click OK button

Write notes

See “Annotate”

Zoom in

1.

Choose Zoom In from Options menu

Zoom out

1.

Choose Zoom Out from Options menu



Rbout Spacetime...
Relp... ®7

Aﬁpendix B: Commands, by Menu

About Spacetime...
Help...

New %N
Open %0
Save %8S
Sauve As...
Revert

Page Setup...
Print... %8P

Quit 20

New

Open

Save
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Here is a complete listing of all the menu commands for
SPACETIME. Some commands in these menus show a
keyboard equivalent. These keyboard equivalents do not
require the simultaneous pressing of the command key,

E3)

Apple () Menu
The Apple menu enables you to look at the SPACETIME
title screen and the help screens.

Displays the SPACETIME title screen

Displays one of the four SPACETIME help screens.
Which screen is displayed depends on which window is in
the front when you choose Help.

File Menu

The File menu provides commands for the following
functions:
» Starting a scenario
* Saving a scenario
* Reverting to a scenario as it was when last saved
* Printing the screen
¢ Quitting the SPACETIME program

You are asked to verify any operation that could result in
losing information.

Creates a new, clean scenario on which to work. This
command is executed by default when a program starts
unless a specific file is being opened.

Enables you to specify a disk file containing a saved
scenario on which to work.

Saves the current scenario to disk, using the existing
name. If the scenario has not yet been saved, Save asks for a
name (see Save As below).



Save as...

Revert
Print...

Quit

vHighway %®1
Space-Time Disgram %2
Table x®3
Split Window %4

Highway
Spacetime Diagram

Table
Split Window

Clock String

Beacon

Object Event

Synchronize clock xY
Align

Delete Object

Enter Bbject...
Edit Ob ject Details... %E
Program Shuttie... %6

Enter Event...
Edit Event...

Clear Rl %A

Clock string

Beacon
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Asks for a name and a destination disk for a file before
saving the scenario.

Returns a scenario to condition when it was last saved.
Prints the contents of the front-most window.

Exits the program, first asking if you want to save any
changes made since the last time the current file was saved.

Windows Menu

The Windows menu controls which window is active and
visible. All windows share the same data, so making a
change on one affects the others. The windows are de-
scribed in the corresponding sections of this manual.

Brings the Highway window to the front of the screen.

Brings the Spacetime Diagram window to the front of the
screen.

Brings the Table window to the front of the screen.

Splits the screen between Highway and Spacetime Dia-
gram.

Objects Menu

The Objects menu provides commands for the following
functions:

» Creating and deleting objects

* Editing (changing) objects

* Synchronizing the clock of an object

* Aligning objects (by changing the time)

* Creating events

¢ Editing (changing) events

* Clearing the scenario of all objects and events

Attaches an infinite string of clocks to a selected rod,
clock, or the shuttle. The clocks are spaced equal units of
distance apart and are synchronized in the selected object’s
frame. If 7 is close to 1, then the spacing between the clocks
is one unit of distance, as measured in the clock rest frame.
If v is closer to 2, then the clocks are separated by two units
of distance as measured in the clock rest frame, etc.

Causes a selected rod or clock to emit flashes of light.
Two flashes are emitted, one in each direction, at each unit
of time in the selected object’s frame, starting at ¢t = 0. The
shuttle cannot be made into a beacon. Neither can light
flashes be made into beacons.



Object Event

Synchronize Clock

Align

Delete Object

Enter Object...

Edit Object Details...

Program Shuttle...

Enter Event...

Edit Event...
Clear All
a1=0.01
at=0.1
voat=1
i=0 0
Set Time... 8T

vStop at events
vRound coordinates

vDisplay Interval ®i

vOBisplay Worldlines %W
2o00m tn %>
Zoom Out .39

ot =0.01,0.1,1

t=0
Set Time. ..

Creates an event at the position of the currently selected
object at the time specified by the current reference clock.

Synchronizes the selected clock with other clocks in its
rest frame.

Select one object, choose this command, then click
another object to change to the time at which the two
objects are aligned. The align command does not work with
two objects in the same velocity lane or with the shuttle.

Removes the selected object from the highway. Pressing

the key or shift-clicking and dragging the object
off of the highway also deletes the object.

Enables you to create an object and numerically specify
its position and speed.

Enables you to change various parameters of the cur-
rently selected object. Use this command to add a descrip-
tion to an object. This description appears in the Table.

Enables you to program the shuttle by changing its speed
numerically. The shuttle remembers the speed change and
jumps between frames at the appropriate time.

Enables you to specify numerically the position and time
of a new event.

Enables you to edit the position and time of a selected
event.

Removes all events from the Spacetime Diagram and all
objects from the highway.

Options Menu

The Options menu provides commands for the following
functions:

* Program choices affecting time changes
* Changing the time to a particular time
* Automatic rounding of pointer coordinates

* Automatic display of intervals and worldlines on
Spacetime Diagram

* Enlarging or reducing the area displayed on the
screen

Sets the time increment used when stepping through
time.

Goes to the time t = 0 in the current reference frame.

Enables you to enter numerically the time to which you
would like to go, as measured in the current reference
frame.
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Stop At Events

Round Coordinates

Display Interval
Display Wordlines
Zoom In
Zoom Qut
Jump To Object *®J
Enter 8, Gamma... %B
Transform Up »®U
Transform Down %D
Last Frame RL
Original Frame
aj=0.5
vaB=0.1
a8=0.05
a0=0.01
2i=0.005
24=0.001
Jump To Object

Enter B, Gamma...

Transform Up
Transform Down

Last Frame

Original Frame
dp=0.1,0.05...

This option has an effect only while you are changing
time incrementally. When checked, every event is shown at
the time it occurs, even if this requires changing the time
less than one full step. This prevents you from time-step-
ping past an event.

When checked, rounds pointer x and ¢ coordinates to the
nearest multiple of 0.25.

When checked, causes the interval to be displayed on all
connections in the Spacetime Diagram. (See “The Spacetime
Diagram”).

When checked, causes worldlines of objects on the
highway to be displayed on the Spacetime Diagram. Dots at
the intersections of the worldlines with the dashed line of
simultaneity show the current position of each object.

Magnifies the scale of the window by a factor of two.
Reduces the scale of the window by a factor of two.

Transform Menu

The Transform menu provides commands for the following
functions:

e Jumping to the frame of an object

¢ Jumping to a specified frame

* Jumping to the original or last frame

* Changing the frame in incremental steps
¢ Choosing the size of the increment

Jumps to the rest frame of the selected object.

Enables you to specify a frame of refcrence, then jumps
to that frame. You can specify numerically either f or y for
the desired frame with respect to the current frame.

Jumps to frame moving with speed df3 in corresponding
direction with respect to this frame.

Transforms to the most recent frame of reference before
the current frame. Using this command repeatedly enables
you to jump back and forth between the two most recent
frames.

Transforms to the original frame of reference.

Sets the value of 98 used in Transform Up and Transform
Down.
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DataTablel.yvs. B

Object B y

Clock A

Rod B
Rod C

Rod D

Rod E




Data Table 2. Lorentz length contraction.
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Object X-position B Length Rod A lengt y
Rod length
Rod A 0.00 0.00 1.00 1.00 1.00
Rod
Rod
Rod
Rod
Data Table 3. Timedilation
Object X position B Clock time clock time Yy
(sec) %oek B timeg
Clock B 0.00 10.0 1.00
Clock
Clock
Clock

Clock
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Questions:

Question 1.

Question 2

Question 3

Question 4

Question 5

Question 6

Question 7

Question 8

Question 9

Conclusion: State clearly and concisely what you learned about how special
relativity affects the measurements of time and length.



